summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-22 18:16:19 +0200
committerSlávek Banko <[email protected]>2021-07-23 11:30:38 +0200
commit9877be51998ac1ad3fb87f388aa123983cc84583 (patch)
tree70c0c53f509ea70d67971aa170420979c8990b41 /CMakeLists.txt
parent982815b69f037be1370e23498e96c70d749a00dd (diff)
downloadkaffeine-9877be51998ac1ad3fb87f388aa123983cc84583.tar.gz
kaffeine-9877be51998ac1ad3fb87f388aa123983cc84583.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 9755721093439febe785b40b2c9975a45e8dfbbf)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 695ea43..1c80379 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,8 +78,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files