summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2021-03-10 10:54:15 +0900
committerMichele Calgaro <[email protected]>2021-03-10 10:54:45 +0900
commit6e4dbcb7ee5acc113ab6d7664850692f04612b80 (patch)
tree8f94de974fe5fbe735d9628cc4f4e08e8806b9e5 /translations/messages/CMakeLists.txt
parent78db2c39a44c6d20258aaf8201df919c2801717f (diff)
downloadkaffeine-6e4dbcb7ee5acc113ab6d7664850692f04612b80.tar.gz
kaffeine-6e4dbcb7ee5acc113ab6d7664850692f04612b80.zip
Copy translations to a new directory layout.
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 7d490344d4ed011703f9583bb2b8de674a705117)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )