summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-06-05 15:35:30 +0200
committerMichele Calgaro <[email protected]>2020-06-06 18:15:42 +0900
commit879d11940771d832e987da215de9f0f396786a3f (patch)
tree0dfc1203b24de78dc4ed21333c85cd5604988e8e /src/Makefile.am
parent3d4cc752db088f4f692d7422a29b4c534add17e4 (diff)
downloadkasablanca-879d11940771d832e987da215de9f0f396786a3f.tar.gz
kasablanca-879d11940771d832e987da215de9f0f396786a3f.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS and rpm spec files. Better detection for OpenSSL headers and libraries. Write a README file. Rework of the help page. Some cosmetics. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 11c5062539a42b939727a3f0f8a6fbacc1b238be)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 8cf8cb2..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,36 +0,0 @@
-# set the include path for X, qt and TDE
-INCLUDES = $(all_includes)
-
-# these are the headers for your project
-noinst_HEADERS = kasablanca.h bookmarkdialog.h customconnectdialog.h fileexistsdialog.h kbitem.h ftplib.h ftpsession.h kbfileinfo.h kbdirinfo.h kbtransferitem.h kbtransferdir.h kbtransferfile.h kbtaskview.h kbbookmarkitem.h kbsiteinfo.h importdialog.h kbstatustip.h
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/kasablanca.pot
-
-KDE_ICON = kasablanca
-
-#########################################################################
-# APPLICATION SECTION
-#########################################################################
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-bin_PROGRAMS = kasablanca
-
-# the application source, library search path, and link libraries
-kasablanca_SOURCES = main.cpp kasablanca.cpp bookmarkdialog.cpp customconnectdialog.cpp fileexistsdialog.cpp kbitem.cpp Q_bookmarkdialog.ui Q_fileexistsdialog.ui Q_mainwindow.ui eventhandler.cpp ftpthread.cpp ftplib.cpp ftpsession.cpp kbfileinfo.cpp kbdirinfo.cpp kbdir.cpp kbfile.cpp kbtransferitem.cpp kbtransferdir.cpp kbtransferfile.cpp kbconfig.kcfgc Q_colorspreferencesdialog.ui Q_generalpreferencesdialog.ui kbtaskview.cpp Q_userinterfacepreferencesdialog.ui kbbookmarkitem.cpp kbsiteinfo.cpp Q_customconnectdialog.ui Q_importdialog.ui importdialog.cpp kbstatustip.cpp
-kasablanca_LDFLAGS = $(TDE_RPATH) $(all_libraries)
-kasablanca_LDADD = -lssl $(LIB_TDEUI) -lcrypto $(LIB_TDECORE) -lDCOP $(LIB_QT)
-
-# this is where the desktop file will go
-xdg_apps_DATA = kasablanca.desktop
-
-# this is where the shell's XML-GUI resource file goes
-shellrcdir = $(kde_datadir)/kasablanca
-shellrc_DATA = kasablancaui.rc about.png
-
-# this is the config xml
-kde_kcfg_DATA=kbconfig.kcfg
-