summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-02-24 14:49:03 +0100
committerSlávek Banko <[email protected]>2019-02-24 15:25:32 +0100
commit80f1da469daa6607762e13231b2103fe6dd40503 (patch)
treee3c7aface5131e9443c75920caeb0f34f8adefbe /CMakeLists.txt
parent66db0a23d76e988b27d4f19cfcf476c3b2bf0df7 (diff)
downloadkbarcode-80f1da469daa6607762e13231b2103fe6dd40503.tar.gz
kbarcode-80f1da469daa6607762e13231b2103fe6dd40503.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 20a84daca2dfed6201373911a0c252f9d36c29c3)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e58336..91dcc39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )