summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-02-24 14:16:00 +0100
committerSlávek Banko <[email protected]>2019-02-24 14:28:39 +0100
commitdabe93bad27870ad3f52ec56c02e090a9384524a (patch)
tree2133e58fbfacfc34f01f09f4340c487f3fe04a4f /CMakeLists.txt
parentee94e3dcbe5a7c9d76a49811e101333d5a6fbf89 (diff)
downloadkbarcode-dabe93bad27870ad3f52ec56c02e090a9384524a.tar.gz
kbarcode-dabe93bad27870ad3f52ec56c02e090a9384524a.zip
cmake: add WITH_NATIVE_GNU_BARCODE and WITH_JAVASCRIPT build options
Signed-off-by: gregory guy <[email protected]> Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18f5ed7..78cc020 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ include( FindPkgConfig )
include( CheckFunctionExists )
include( CheckSymbolExists )
include( CheckIncludeFile )
+include( CheckIncludeFileCXX )
include( CheckLibraryExists )
include( CheckCSourceCompiles )
include( CheckCXXSourceCompiles )
@@ -43,6 +44,8 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_NATIVE_GNU_BARCODE "Enable GNU Barcode" OFF )
+option( WITH_JAVASCRIPT "Enable Javascript" ${WITH_ALL_OPTIONS} )
##### user requested modules