summaryrefslogtreecommitdiffstats
path: root/kbarcode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kbarcode/CMakeLists.txt')
-rw-r--r--kbarcode/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/kbarcode/CMakeLists.txt b/kbarcode/CMakeLists.txt
index a16fbb0..dbfaab2 100644
--- a/kbarcode/CMakeLists.txt
+++ b/kbarcode/CMakeLists.txt
@@ -70,19 +70,23 @@ tde_install_icons( )
##### other data
-install(
- FILES
+foreach( _desktop
${PROJECT_NAME}.desktop
${PROJECT_NAME}-batch.desktop
${PROJECT_NAME}-editor.desktop
${PROJECT_NAME}-single.desktop
+ )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
+ )
+endforeach( )
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
-install(
- FILES ${PROJECT_NAME}-label.desktop
+tde_create_translated_desktop(
+ SOURCE ${PROJECT_NAME}-label.desktop
DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
install(