summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2023-02-19 15:40:48 +0100
committerSlávek Banko <[email protected]>2023-02-19 15:44:39 +0100
commitece5ecce2586d96c8c3c10203f427510edc30f31 (patch)
treeed92a1dc133e2a3f7456a369e9726bc119dbc8fa /src/CMakeLists.txt
parent9818b210e2163e93e67a40b75b7420feae9c4e16 (diff)
downloadkbfx-ece5ecce2586d96c8c3c10203f427510edc30f31.tar.gz
kbfx-ece5ecce2586d96c8c3c10203f427510edc30f31.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Added translation of .desktop files. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7a66ab8..9b9978c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -48,4 +48,7 @@ tde_add_kpart( ${target} AUTOMOC
##### desktop files ###############################
-INSTALL(FILES kbfxspinx.desktop DESTINATION ${DATA_INSTALL_DIR}/kicker/applets)
+tde_create_translated_desktop(
+ SOURCE kbfxspinx.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+)