summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-06-12 15:04:23 +0200
committergregory guy <[email protected]>2020-06-16 14:18:31 +0200
commitce2ef1f4f8f62e74c007566908e0b1bc83894f87 (patch)
tree1ee2eaa7091b004c4d570df1fe53d0259d40ac87 /CMakeLists.txt
parent84063aa8b6e5d3f73d07934522fb43d387305d93 (diff)
downloadkchmviewer-ce2ef1f4f8f62e74c007566908e0b1bc83894f87.tar.gz
kchmviewer-ce2ef1f4f8f62e74c007566908e0b1bc83894f87.zip
Drop automake build support.
Add basic cmake instructions with new file INSTALL. Add an AUTHOR file. Rework of the README file. Removed unnecessary files lchmurlhandler.cpp, lchmurlhandler.h, qt34.cpp and qt34.h. Removed the install of the static lib libchmfile. Removed the kchmdcopiface_skel.cpp file, this file should be created at build time. Moved the desktop file kchmviewer.desktop into the XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebd32a3..d3e4c4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,17 +41,17 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
-option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-option( WITH_TDE "Build with TDE itegration instead of standalone TQt" ${WITH_ALL_OPTIONS} )
-option( WITH_CHMLIB "Build with external chmlib" ${WITH_ALL_OPTIONS} )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_TDE "Build with TDE itegration instead of standalone TQt" ${WITH_ALL_OPTIONS} )
+option( WITH_CHMLIB "Build with external chmlib" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -72,7 +72,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( lib )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )