summaryrefslogtreecommitdiffstats
path: root/cert-updater/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-01-04 23:04:03 +0100
committerSlávek Banko <[email protected]>2019-01-05 19:57:29 +0100
commit2ad893acefa0359d39d8064c4c9d07cf5b0de267 (patch)
treed1c7c3ff9d76f0bf688cbefda2ffba5a2f26ba47 /cert-updater/CMakeLists.txt
parentc94ce32241b12687bf9a8cf6d233f3c378ac8e39 (diff)
downloadkcmldap-2ad893acefa0359d39d8064c4c9d07cf5b0de267.tar.gz
kcmldap-2ad893acefa0359d39d8064c4c9d07cf5b0de267.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 4a479930bbaafbeeaaf525507eb0af47ea2adcd2)
Diffstat (limited to 'cert-updater/CMakeLists.txt')
-rw-r--r--cert-updater/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/cert-updater/CMakeLists.txt b/cert-updater/CMakeLists.txt
new file mode 100644
index 0000000..8def08e
--- /dev/null
+++ b/cert-updater/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeldapcertupdater (executable)
+
+tde_add_executable( tdeldapcertupdater AUTOMOC
+
+ SOURCES
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ ${LIBTDELDAP_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)