summaryrefslogtreecommitdiffstats
path: root/cert-updater/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-01-04 23:04:03 +0100
committergregory guy <[email protected]>2019-01-04 23:04:03 +0100
commit4a479930bbaafbeeaaf525507eb0af47ea2adcd2 (patch)
tree08cb28d533bcd21ed01da07d734990d612bef09a /cert-updater/CMakeLists.txt
parentec7d3bd017cec514f434457c101a6982a17cb32d (diff)
downloadkcmldap-4a479930bbaafbeeaaf525507eb0af47ea2adcd2.tar.gz
kcmldap-4a479930bbaafbeeaaf525507eb0af47ea2adcd2.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'cert-updater/CMakeLists.txt')
-rw-r--r--cert-updater/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/cert-updater/CMakeLists.txt b/cert-updater/CMakeLists.txt
new file mode 100644
index 0000000..8def08e
--- /dev/null
+++ b/cert-updater/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeldapcertupdater (executable)
+
+tde_add_executable( tdeldapcertupdater AUTOMOC
+
+ SOURCES
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ ${LIBTDELDAP_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)