summaryrefslogtreecommitdiffstats
path: root/src/secondaryrealmwizard/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-04-03 18:19:30 +0200
committergregory guy <[email protected]>2019-04-05 17:11:45 +0200
commit307a1a53261669dc8d1d2ee031a8927f64ddb27a (patch)
treec7b4aa825a12858f3c4fffc0bc7fda19a9102ca3 /src/secondaryrealmwizard/CMakeLists.txt
parentf0e9b7cf4f429387055108e3c94b9bfc39c5fba0 (diff)
downloadkcmldapcontroller-307a1a53261669dc8d1d2ee031a8927f64ddb27a.tar.gz
kcmldapcontroller-307a1a53261669dc8d1d2ee031a8927f64ddb27a.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/secondaryrealmwizard/CMakeLists.txt')
-rw-r--r--src/secondaryrealmwizard/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/secondaryrealmwizard/CMakeLists.txt b/src/secondaryrealmwizard/CMakeLists.txt
new file mode 100644
index 0000000..fce3301
--- /dev/null
+++ b/src/secondaryrealmwizard/CMakeLists.txt
@@ -0,0 +1,32 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${CMAKE_SOURCE_DIR}/src
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### secondaryrealmwizard (static)
+
+tde_add_library( secondaryrealmwizard STATIC_PIC AUTOMOC
+
+ SOURCES
+ realmintropagedlg.ui
+ certconfigpagedlg.ui
+ realmconfigpagedlg.ui
+ realmfinishpagedlg.ui
+ secondaryrealmwizard.cpp
+ certconfigpage.cpp
+ realmintropage.cpp
+ realmconfigpage.cpp
+ realmfinishpage.cpp
+)