summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:58:10 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:48:59 +0900
commitbbefc9a24e8645c8e7da274856de55d2256de005 (patch)
tree2a9083a8e2fe475f651023ad0d9161446a699848 /CMakeLists.txt
parent446b4aaf79cec4331bffdbdb25e816987123a920 (diff)
downloadkcmldapmanager-bbefc9a24e8645c8e7da274856de55d2256de005.tar.gz
kcmldapmanager-bbefc9a24e8645c8e7da274856de55d2256de005.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit a9c164dc4ee694b14bda7287c242eec8a78373cd)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10d9b44..0bf22f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )