summaryrefslogtreecommitdiffstats
path: root/cmdline/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-03-15 10:58:02 +0100
committergregory guy <[email protected]>2019-03-27 13:59:33 +0100
commit67025db14ed3496a7977682e1c5c282e630abc4e (patch)
treeae4455b24b9ef3c2e66062a478797d7e32829ca5 /cmdline/CMakeLists.txt
parentdbab0cd0ca4ccdf685ffa265671e65cd4d06fcaa (diff)
downloadkcmldapmanager-67025db14ed3496a7977682e1c5c282e630abc4e.tar.gz
kcmldapmanager-67025db14ed3496a7977682e1c5c282e630abc4e.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'cmdline/CMakeLists.txt')
-rw-r--r--cmdline/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/cmdline/CMakeLists.txt b/cmdline/CMakeLists.txt
new file mode 100644
index 0000000..567f381
--- /dev/null
+++ b/cmdline/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeldapmanager (executable)
+
+tde_add_executable( tdeldapmanager AUTOMOC
+
+ SOURCES
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ ${TDELDAP_LIBRARIES}
+ ${KRB5_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)