summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-28 10:53:51 +0200
committerSlávek Banko <[email protected]>2020-06-28 10:53:51 +0200
commit509de40974962520faee091c89ce8281c0d7c0bc (patch)
tree11f6ba3e78eeb8ac4245bb9f4542cddcc21d4a63 /src/CMakeLists.txt
parent8dfa8ebe8d0a0590cf2c74f7ccdd86dac4d30908 (diff)
downloadkdiff3-509de40974962520faee091c89ce8281c0d7c0bc.tar.gz
kdiff3-509de40974962520faee091c89ce8281c0d7c0bc.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c6def85..3c8d7c7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -72,8 +72,8 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-install(
- FILES kdiff3part.desktop
+tde_create_translated_desktop(
+ SOURCE kdiff3part.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
)
@@ -82,7 +82,4 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/kdiff3part
)
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )