summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-06-27 14:46:01 +0200
committergregory guy <[email protected]>2020-06-27 14:46:01 +0200
commite14732aa76b0fc20b955da434b1e2e92012c34e8 (patch)
tree5dfb589ae107ddaa2288783aa78f80b5dc3ff894 /src/Makefile.am
parenteadb41b09fb5d6e46cf98c0d6dee1723c8307d89 (diff)
downloadkdiff3-e14732aa76b0fc20b955da434b1e2e92012c34e8.tar.gz
kdiff3-e14732aa76b0fc20b955da434b1e2e92012c34e8.zip
Drop automake build support.
Add basic cmake build instructions. Delete the NEWS file. Rework of the README. The man folder has been moved into the doc folder for consistency with what have been done so far. The html pages have been moved into the doc folder as well. Some cosmetics. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am58
1 files changed, 0 insertions, 58 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 1212c3d..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,58 +0,0 @@
-
-# set the include path for X, qt and KDE
-INCLUDES = $(all_includes)
-
-# these are the headers for your project
-noinst_HEADERS = kdiff3_part.h kdiff3_shell.h kdiff3.h common.h diff.h \
- directorymergewindow.h merger.h optiondialog.h fileaccess.h version.h \
- smalldialogs.h difftextwindow.h mergeresultwindow.h
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/kdiff3.pot
-
-KDE_ICON = kdiff3
-
-# this Makefile creates both a KPart application and a KPart
-#########################################################################
-# APPLICATION SECTION
-#########################################################################
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-bin_PROGRAMS = kdiff3
-
-# the application source, library search path, and link libraries
-kdiff3_SOURCES = main.cpp kdiff3_shell.cpp
-kdiff3_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
-kdiff3_LDADD = $(LIB_TDEPARTS)
-
-# this is where the desktop file will go
-shelldesktopdir = $(kde_appsdir)/Development
-shelldesktop_DATA = kdiff3.desktop
-
-# this is where the shell's XML-GUI resource file goes
-shellrcdir = $(kde_datadir)/kdiff3
-shellrc_DATA = kdiff3_shell.rc
-
-#########################################################################
-# KPART SECTION
-#########################################################################
-kde_module_LTLIBRARIES = libkdiff3part.la
-
-# the Part's source, library search path, and link libraries
-libkdiff3part_la_SOURCES = kdiff3_part.cpp kdiff3.cpp directorymergewindow.cpp \
- merger.cpp pdiff.cpp difftextwindow.cpp diff.cpp optiondialog.cpp \
- mergeresultwindow.cpp fileaccess.cpp gnudiff_analyze.cpp gnudiff_io.cpp gnudiff_xmalloc.cpp \
- common.cpp smalldialogs.cpp
-libkdiff3part_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) $(LIB_TQT)
-libkdiff3part_la_LIBADD = $(LIB_TDECORE) $(LIB_TDEUI) $(LIB_TDEPRINT) $(LIB_TDEPARTS) $(LIB_TDEFILE)
-
-# this is where the desktop file will go
-partdesktopdir = $(kde_servicesdir)
-partdesktop_DATA = kdiff3part.desktop
-
-# this is where the part's XML-GUI resource file goes
-partrcdir = $(kde_datadir)/kdiff3part
-partrc_DATA = kdiff3_part.rc