summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a73b52e..253e723 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,8 +25,8 @@ bin_PROGRAMS = kdiff3
# the application source, library search path, and link libraries
kdiff3_SOURCES = main.cpp kdiff3_shell.cpp
-kdiff3_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
-kdiff3_LDADD = $(LIB_KPARTS)
+kdiff3_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+kdiff3_LDADD = $(LIB_TDEPARTS)
# this is where the desktop file will go
shelldesktopdir = $(kde_appsdir)/Development
@@ -47,7 +47,7 @@ libkdiff3part_la_SOURCES = kdiff3_part.cpp kdiff3.cpp directorymergewindow.cpp \
mergeresultwindow.cpp fileaccess.cpp gnudiff_analyze.cpp gnudiff_io.cpp gnudiff_xmalloc.cpp \
common.cpp smalldialogs.cpp
libkdiff3part_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) $(LIB_QT)
-libkdiff3part_la_LIBADD = $(LIB_TDEPRINT) $(LIB_KPARTS) $(LIB_TDEFILE)
+libkdiff3part_la_LIBADD = $(LIB_TDEPRINT) $(LIB_TDEPARTS) $(LIB_TDEFILE)
# this is where the desktop file will go
partdesktopdir = $(kde_servicesdir)