summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 10:30:08 +0200
committerSlávek Banko <[email protected]>2021-07-26 10:30:08 +0200
commitb0a9a8156dc3eb9583a14278a6faf98f53f8fd7c (patch)
tree6e760651021ff76b76ff00e409ec2f4ed262afcf /CMakeLists.txt
parentbb4f8aa2c22626f64ea11e81da36d99340feef20 (diff)
downloadkdpkg-b0a9a8156dc3eb9583a14278a6faf98f53f8fd7c.tar.gz
kdpkg-b0a9a8156dc3eb9583a14278a6faf98f53f8fd7c.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1cb54b..70d5cea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,8 +71,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( icon )
add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( ${PROJECT_NAME}-install )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files