summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:58:22 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:49:21 +0900
commit52afc69c577b66b7e0cc42aeb876446cf8ef3160 (patch)
tree81533a9886fca9d65084e5470eddb0033d43e80e /CMakeLists.txt
parent0b9aad728e05b4d1e12b9047dd7979c92c6899c0 (diff)
downloadkerberostray-52afc69c577b66b7e0cc42aeb876446cf8ef3160.tar.gz
kerberostray-52afc69c577b66b7e0cc42aeb876446cf8ef3160.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 6d6257deb6cb899d14bc02bc38e972d58bdb94c9)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b4b89d..00cbd42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )