summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-09-29 09:31:20 +0200
committergregory guy <[email protected]>2020-09-29 09:31:20 +0200
commit65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7 (patch)
treed16720590ea865b858be0c6a04e7e0918beaa4ea /src/Makefile.am
parent66d9fc4d1381b024cca425f30e297662a5d70cf2 (diff)
downloadkerberostray-65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7.tar.gz
kerberostray-65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder doc. Delete empty files NEWS and TODO. Add a README file. Some cosmetics. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 0 insertions, 26 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 3de550f..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,26 +0,0 @@
-INCLUDES= $(all_includes) $(KDE_INCLUDES)/tde $(KRB5_CFLAGS)
-
-bin_PROGRAMS = kerberostray
-
-kerberostray_SOURCES = main.cpp toplevel.cpp configdlgbase.ui configdlg.cpp
-
-kerberostray_METASOURCES = AUTO
-kerberostray_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor -ltdeldap $(KRB5_LIBS)
-
-# LIB_TDEIO needed for KNotifyDialog
-kerberostray_LDADD = $(LIB_TDEUI) $(LIB_TDEIO)
-
-KDE_ICON = kerberostray
-
-KDE_OPTIONS = nofinal
-
-kerberostrayicondir = $(kde_datadir)/kerberostray/icons
-kerberostrayicon_ICON = AUTO
-
-messages:
- $(XGETTEXT) $(kerberostray_SOURCES) -o $(podir)/kerberostray.pot
-
-xdg_apps_DATA = kerberostray.desktop
-
-autostart_DATA = kerberostray.desktop
-autostartdir = $(datadir)/autostart