summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:55:12 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:45:43 +0900
commit20ad9ac530db499bdc627d0e4c40e437bdc62a8a (patch)
treedc6876c593ce76015772e9048b7b505e215adbd6 /CMakeLists.txt
parent188e5fcea58f1dea99a69953f81d1c74903adbd3 (diff)
downloadkftpgrabber-20ad9ac530db499bdc627d0e4c40e437bdc62a8a.tar.gz
kftpgrabber-20ad9ac530db499bdc627d0e4c40e437bdc62a8a.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 96eabfd3eaa674faa71a3b4632b1a35d1f83601f)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da8f78e..f49eeed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )