summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-12-13 02:36:49 +0100
committerSlávek Banko <[email protected]>2018-12-13 02:36:49 +0100
commitd754910274408fa59eceedd1bba3339df800de1c (patch)
treede832a671806fdc5c7e9d142b8cab64bf175d407 /po/CMakeLists.txt
parent209a85e33d013c6b24549f528a51b543816ebe34 (diff)
downloadkiosktool-d754910274408fa59eceedd1bba3339df800de1c.tar.gz
kiosktool-d754910274408fa59eceedd1bba3339df800de1c.zip
Add CMakeL10n rules.
Create translation template. Modify CMake rules for translations to make them independent of languages. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 6d0aa9f..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1 +1,9 @@
-tde_auto_add_subdirectories( )
+# build translations if some are already available
+
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )