summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:04:33 +0900
committerMichele Calgaro <[email protected]>2024-03-17 11:10:43 +0900
commitd685b485507436477e463c131c8d679f912e07d1 (patch)
tree47036e21f3285fc4c41bfe404956aa8dbc7a8307 /CMakeLists.txt
parentf14c6e5f7c4dbdd5adf111567f6b13a01fc1b4d4 (diff)
downloadkkbswitch-d685b485507436477e463c131c8d679f912e07d1.tar.gz
kkbswitch-d685b485507436477e463c131c8d679f912e07d1.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7c0c5f..1d08c3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )