summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:07:06 +0900
committerMichele Calgaro <[email protected]>2024-03-17 11:10:48 +0900
commita6e2f4d194bef07f1c953cf13f8bde058be0f6a4 (patch)
tree6d10e229b169368a3c16b7faca6ad820831a9f35 /CMakeLists.txt
parent691489dddc259e7d7c463bde3347d7cea780d54f (diff)
downloadklamav-a6e2f4d194bef07f1c953cf13f8bde058be0f6a4.tar.gz
klamav-a6e2f4d194bef07f1c953cf13f8bde058be0f6a4.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1869d80..9a4b9b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -35,11 +40,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )