summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-03-03 12:29:36 +0100
committerSlávek Banko <[email protected]>2021-03-03 12:29:36 +0100
commit8789defb6025aac55ca748e6b64cfe0ceb8cbf2a (patch)
treed605222b3ead80c2d1a50b7c8a5791d91f52ef66 /po/CMakeLists.txt
parentc8b0ade1ef2cfa2d726bd9778f74f0aa7d8e3bfc (diff)
downloadkmplayer-8789defb6025aac55ca748e6b64cfe0ceb8cbf2a.tar.gz
kmplayer-8789defb6025aac55ca748e6b64cfe0ceb8cbf2a.zip
Remove the original translation directory layout.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/po/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )