summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-03-03 12:23:30 +0100
committerSlávek Banko <[email protected]>2021-03-03 12:23:30 +0100
commitc8b0ade1ef2cfa2d726bd9778f74f0aa7d8e3bfc (patch)
tree9b54d4aa6f1225cd873022a0778374261bab36a8 /translations/messages/CMakeLists.txt
parent95a6a36403a289814bb252cd5496e4d67d331b11 (diff)
downloadkmplayer-c8b0ade1ef2cfa2d726bd9778f74f0aa7d8e3bfc.tar.gz
kmplayer-c8b0ade1ef2cfa2d726bd9778f74f0aa7d8e3bfc.zip
Copy translations to a new directory layout.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )