summaryrefslogtreecommitdiffstats
path: root/KMFIPTInterface/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 01:04:17 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 01:04:17 +0000
commitc3b707c026782768bd8c0e6ae6b574fe8a36802d (patch)
tree5ca6782031b1546c788290cc0b95524369ff01ea /KMFIPTInterface/Makefile.am
downloadkmyfirewall-c3b707c026782768bd8c0e6ae6b574fe8a36802d.tar.gz
kmyfirewall-c3b707c026782768bd8c0e6ae6b574fe8a36802d.zip
Added old abandoned KDE3 version of kmyfirewall
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kmyfirewall@1091559 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'KMFIPTInterface/Makefile.am')
-rw-r--r--KMFIPTInterface/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/KMFIPTInterface/Makefile.am b/KMFIPTInterface/Makefile.am
new file mode 100644
index 0000000..c8b96ab
--- /dev/null
+++ b/KMFIPTInterface/Makefile.am
@@ -0,0 +1,17 @@
+bin_PROGRAMS = kmfiptinterface
+INCLUDES = $(all_includes)
+kmfiptinterface_LDFLAGS = -module $(all_libraries) $(KDE_RPATH)
+kmfiptinterface_LDADD = $(LIB_KIO)
+kmfiptinterface_SOURCES = main.cpp kmfiptinterface.cpp iptchecker.cpp kmfiptinterface.skel
+
+
+noinst_HEADERS = kmfiptinterface.h iptchecker.h
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/dcoptest.pot
+
+
+service_DATA = kmfiptinterface.desktop
+servicedir = $(kde_servicesdir)