summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-03-17 18:50:52 +0100
committerSlávek Banko <[email protected]>2022-03-20 18:50:39 +0100
commit49e34b02b0bb609ce6e9ff1d2d96bdfcb03617d1 (patch)
treef8299219a274dedc710b0bbf0ff1be832d47f197 /CMakeLists.txt
parenta553069ad068dcab541282df24dbe12591153af8 (diff)
downloadkmymoney-49e34b02b0bb609ce6e9ff1d2d96bdfcb03617d1.tar.gz
kmymoney-49e34b02b0bb609ce6e9ff1d2d96bdfcb03617d1.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 5e6c401557744fe5f9765471605cc793939fee1f)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e22c63..487e6b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST -UQT_NO_STL )
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_STL )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )