summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 16:56:14 +0200
committerSlávek Banko <[email protected]>2021-07-26 16:56:25 +0200
commitcaa82d89e51cf9e0b03482c0535fc6fbce7380e6 (patch)
treefc64aaa39d6a257d905fc9b5a0225eac889c81e5 /translations/messages/CMakeLists.txt
parente8c747773a9ba0d6e9b8ea02f965aa35550adaa6 (diff)
downloadknetload-caa82d89e51cf9e0b03482c0535fc6fbce7380e6.tar.gz
knetload-caa82d89e51cf9e0b03482c0535fc6fbce7380e6.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 709891637733f1a4fd5b249b3f41d7b1501fb8e9)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/translations/messages/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )