summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2018-10-23 14:08:03 +0200
committergregory guy <[email protected]>2018-10-23 14:08:03 +0200
commiteeefa496afbc5025420f1e1c30c1b2ca59fd4353 (patch)
treeb60dad2e6a63d9a1d2e75dd64d32c38ae98308bf /src/CMakeLists.txt
parentf45f6657b51e18dbfb82b5aead54af134b3eefd3 (diff)
downloadknetstats-eeefa496afbc5025420f1e1c30c1b2ca59fd4353.tar.gz
knetstats-eeefa496afbc5025420f1e1c30c1b2ca59fd4353.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..93766be
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+
+
+##### icons
+
+tde_install_icons( ${PROJECT_NAME} )
+
+
+##### other data
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)