summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-10-22 04:10:08 +0200
committerSlávek Banko <[email protected]>2018-10-22 18:42:36 +0200
commit83fb5c2a160acd743fe6beab0dca68a5ad8faf21 (patch)
treec150bd4d9daeaa099a9bb472c1484b2c3b81a6e9 /CMakeLists.txt
parenta83f600010c3c5d097c64ff3847ff59f2b2eaf7e (diff)
downloadknmap-83fb5c2a160acd743fe6beab0dca68a5ad8faf21.tar.gz
knmap-83fb5c2a160acd743fe6beab0dca68a5ad8faf21.zip
Removed obsolete Qt2's ASSERT and replace with Q_ASSERT.
The definition of -UTQT_NO_COMPAT is no longer needed. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 45e95597267482ddb1023b33ebeeb50597d91508)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5fffe51..0d80651 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST -UQT_NO_COMPAT )
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )