summaryrefslogtreecommitdiffstats
path: root/example/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /example/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
new file mode 100644
index 00000000..55b98290
--- /dev/null
+++ b/example/Makefile.am
@@ -0,0 +1,38 @@
+
+INCLUDES = $(KOFFICE_INCLUDES) $(all_includes)
+
+## The part
+kde_module_LTLIBRARIES = libexamplepart.la
+libexamplepart_la_SOURCES = example_part.cc \
+ example_view.cc example_factory.cc
+libexamplepart_la_LDFLAGS = $(KDE_PLUGIN)
+libexamplepart_la_LIBADD = $(LIB_KOFFICEUI)
+
+## The kdeinit loadable module and executable
+kdeinit_LTLIBRARIES = example.la
+lib_LTLIBRARIES =
+bin_PROGRAMS =
+example_la_SOURCES = main.cc
+example_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+example_la_LIBADD = $(LIB_KOFFICEUI)
+
+METASOURCES = AUTO
+
+kdelnk_DATA = example.desktop
+kdelnkdir = $(kde_appsdir)/Office
+
+# Note: for your application, the mime type should be defined in
+# kdelibs CVS HEAD and a compatibility entry should be added in
+# the directory koffice/mimetypes/kde??
+# where ?? is the version number of the last stable kde(libs) release.
+kdemime_DATA = x-vnd.kde.example.desktop
+kdemimedir = $(kde_mimedir)/application
+
+rc_DATA = example.rc example_readonly.rc
+rcdir = $(kde_datadir)/example
+
+messages: rc.cpp
+ $(XGETTEXT) rc.cpp *.cc example_aboutdata.h -o $(podir)/example.pot
+kde_services_DATA = examplepart.desktop
+
+include $(top_srcdir)/admin/Doxyfile.am