summaryrefslogtreecommitdiffstats
path: root/kexi/formeditor/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kexi/formeditor/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kexi/formeditor/Makefile.am')
-rw-r--r--kexi/formeditor/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/kexi/formeditor/Makefile.am b/kexi/formeditor/Makefile.am
new file mode 100644
index 00000000..8f8aacbe
--- /dev/null
+++ b/kexi/formeditor/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/kexi/Makefile.global
+
+INCLUDES = -I$(top_srcdir)/kexi/widget -I$(top_srcdir)/kexi/widget/utils \
+ -I$(top_srcdir)/kexi/widget/tableview \
+ -I$(top_srcdir)/kexi/core \
+ -I$(top_srcdir)/kexi \
+ -I$(top_srcdir)/lib/kofficecore \
+ -I$(top_srcdir)/lib -I$(top_srcdir)/lib/koproperty $(all_includes)
+
+lib_LTLIBRARIES = libkformdesigner.la
+libkformdesigner_la_LDFLAGS = -no-undefined $(all_libraries) $(VER_INFO)
+libkformdesigner_la_SOURCES = container.cpp resizehandle.cpp widgetfactory.cpp \
+ widgetlibrary.cpp libactionwidget.cpp form.cpp \
+ objecttree.cpp formIO.cpp formmanager.cpp objecttreeview.cpp spring.cpp \
+ commands.cpp events.cpp connectiondialog.cpp richtextdialog.cpp \
+ tabstopdialog.cpp editlistviewdialog.cpp utils.cpp widgetpropertyset.cpp \
+ kfdpixmapedit.cpp widgetwithsubpropertiesinterface.cpp
+
+METASOURCES = AUTO
+libkformdesigner_la_LIBADD = \
+ $(top_builddir)/kexi/widget/libkexiextendedwidgets.la \
+ $(top_builddir)/kexi/widget/utils/libkexiguiutils.la \
+ $(top_builddir)/kexi/widget/tableview/libkexidatatable.la \
+ $(top_builddir)/lib/koproperty/libkoproperty.la \
+ $(LIB_KPARTS)
+
+servicetypesdir = $(kde_servicetypesdir)
+servicetypes_DATA=widgetfactory.desktop
+
+SUBDIRS = . factories #test #scripting #kdevelop_plugin
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` >> rc.cpp
+ $(XGETTEXT) `find . -name "*.cpp" -o -name "*.h"` -o $(podir)/kformdesigner.pot