summaryrefslogtreecommitdiffstats
path: root/kexi/plugins/relations/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2012-06-13 08:37:52 +0200
committerSlávek Banko <[email protected]>2012-06-13 08:37:52 +0200
commit5c69fcd39111465de16c933763d3c918703048d8 (patch)
treeccd0a0cf7e7d30a8ebe16a71e7e26ede6ee7a66c /kexi/plugins/relations/Makefile.am
parent17477649bd724528a78e6c772244dc1a63f38202 (diff)
downloadkoffice-5c69fcd39111465de16c933763d3c918703048d8.tar.gz
koffice-5c69fcd39111465de16c933763d3c918703048d8.zip
Fix FTBFS due to missing libraries
Clean up lib paths in LDFLAGS - moved to LIBADD For KWord and and KPresenter added linking kspell2 For KSpread added linking kutils This closes Bug 657
Diffstat (limited to 'kexi/plugins/relations/Makefile.am')
-rw-r--r--kexi/plugins/relations/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/kexi/plugins/relations/Makefile.am b/kexi/plugins/relations/Makefile.am
index 47a263a5..779b47e3 100644
--- a/kexi/plugins/relations/Makefile.am
+++ b/kexi/plugins/relations/Makefile.am
@@ -8,9 +8,11 @@ kde_module_LTLIBRARIES = kexihandler_relation.la
kexihandler_relation_la_SOURCES = kexirelationpartimpl.cpp \
kexirelationmaindlg.cpp
-kexihandler_relation_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts -L../../../lib/kofficecore/.libs/ -lkofficecore -L../../../lib/kofficeui/.libs/ -lkofficeui -L../../../lib/store/.libs/ -lkstore -L../../../kexi/kexidb/.libs/ -lkexidb -L../../../kexi/kexiutils/.libs/ -lkexiutils
-kexihandler_relation_la_LIBADD = ../../core/libkexicore.la \
- ../../widget/relations/libkexirelationsview.la
+kexihandler_relation_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts
+kexihandler_relation_la_LIBADD = $(KOFFICE_LIBS) ../../core/libkexicore.la \
+ ../../widget/relations/libkexirelationsview.la \
+ ../../../kexi/kexidb/libkexidb.la \
+ ../../../kexi/kexiutils/libkexiutils.la
INCLUDES= -I$(top_srcdir)/kexi/core -I$(top_srcdir)/kexi \
-I$(top_srcdir)/kexi/widget -I$(top_srcdir)/kexi/widget/relations \