summaryrefslogtreecommitdiffstats
path: root/krita/plugins/tools/tool_polygon/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /krita/plugins/tools/tool_polygon/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'krita/plugins/tools/tool_polygon/Makefile.am')
-rw-r--r--krita/plugins/tools/tool_polygon/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/krita/plugins/tools/tool_polygon/Makefile.am b/krita/plugins/tools/tool_polygon/Makefile.am
new file mode 100644
index 00000000..dec22b37
--- /dev/null
+++ b/krita/plugins/tools/tool_polygon/Makefile.am
@@ -0,0 +1,35 @@
+kde_services_DATA = kritatoolpolygon.desktop
+
+# all_includes must remain last!
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../kritacolor/ \
+ -I$(srcdir)/../../../ui \
+ -I$/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+kritatoolpolygon_la_SOURCES = \
+ tool_polygon.cc \
+ kis_tool_polygon.cc
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kritatoolpolygon.la
+
+noinst_HEADERS = \
+ tool_polygon.h \
+ kis_tool_polygon.h
+
+kritatoolpolygon_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kritatoolpolygon_la_LIBADD = ../../../libkritacommon.la
+
+kritatoolpolygon_la_METASOURCES = AUTO
+
+KDE_OPTIONS = nofinal
+
+kritapics_DATA = \
+ tool_polygon_cursor.png \
+ tool_polygon.png
+
+kritapicsdir = $(kde_datadir)/krita/pics
+