summaryrefslogtreecommitdiffstats
path: root/kword/mailmerge/kspread/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2012-06-13 08:37:52 +0200
committerSlávek Banko <[email protected]>2012-06-13 08:37:52 +0200
commit5c69fcd39111465de16c933763d3c918703048d8 (patch)
treeccd0a0cf7e7d30a8ebe16a71e7e26ede6ee7a66c /kword/mailmerge/kspread/Makefile.am
parent17477649bd724528a78e6c772244dc1a63f38202 (diff)
downloadkoffice-5c69fcd39111465de16c933763d3c918703048d8.tar.gz
koffice-5c69fcd39111465de16c933763d3c918703048d8.zip
Fix FTBFS due to missing libraries
Clean up lib paths in LDFLAGS - moved to LIBADD For KWord and and KPresenter added linking kspell2 For KSpread added linking kutils This closes Bug 657
Diffstat (limited to 'kword/mailmerge/kspread/Makefile.am')
-rw-r--r--kword/mailmerge/kspread/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/kword/mailmerge/kspread/Makefile.am b/kword/mailmerge/kspread/Makefile.am
index dfb5e2d6..04bb0b15 100644
--- a/kword/mailmerge/kspread/Makefile.am
+++ b/kword/mailmerge/kspread/Makefile.am
@@ -6,8 +6,8 @@ INCLUDES = $(KOFFICE_INCLUDES) $(KOTEXT_INCLUDES) \
kde_module_LTLIBRARIES = kwmailmerge_kspread.la
kwmailmerge_kspread_la_SOURCES = kwmailmerge_kspread.cpp kwmailmerge_kspread_config.cpp
-kwmailmerge_kspread_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -lDCOP -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts -L../../../lib/kofficecore/.libs/ -lkofficecore -L../../../lib/kofficeui/.libs/ -lkofficeui -L../../../lib/store/.libs/ -lkstore
-kwmailmerge_kspread_la_LIBADD = ../../libkwmailmerge_interface.la \
+kwmailmerge_kspread_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -lDCOP -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts
+kwmailmerge_kspread_la_LIBADD = $(KOFFICE_LIBS) ../../libkwmailmerge_interface.la \
$(top_builddir)/kspread/libkspreadcommon.la $(LIB_TDEUI)
METASOURCES = AUTO