summaryrefslogtreecommitdiffstats
path: root/kword/tests/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kword/tests/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kword/tests/Makefile.am')
-rw-r--r--kword/tests/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kword/tests/Makefile.am b/kword/tests/Makefile.am
new file mode 100644
index 00000000..5b316ce7
--- /dev/null
+++ b/kword/tests/Makefile.am
@@ -0,0 +1,25 @@
+AM_CPPFLAGS = -I$(srcdir)/../ $(KOFFICE_INCLUDES) $(KOPAINTER_INCLUDES) $(all_includes)
+
+INCLUDES = $(KOFFICE_INCLUDES) $(KOTEXT_INCLUDES) $(all_includes)
+
+# The check_ target makes sure we don't install the modules,
+# $(KDE_CHECK_PLUGIN) assures a shared library is created.
+check_LTLIBRARIES = kunittest_KWPageManagerTester.la \
+ kunittest_FrameTester.la \
+ kunittest_FrameViewTester.la
+
+kunittest_KWPageManagerTester_la_SOURCES = KWPageManagerTester.cpp
+kunittest_KWPageManagerTester_la_LIBADD = -lkunittest ../libkwordprivate.la
+kunittest_KWPageManagerTester_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+
+kunittest_FrameTester_la_SOURCES = FrameTester.cpp
+kunittest_FrameTester_la_LIBADD = -lkunittest ../libkwordprivate.la
+kunittest_FrameTester_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+
+kunittest_FrameViewTester_la_SOURCES = FrameViewTester.cpp
+kunittest_FrameViewTester_la_LIBADD = -lkunittest ../libkwordprivate.la
+kunittest_FrameViewTester_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+
+check-local: kunittest_KWPageManagerTester.la kunittest_FrameTester.la kunittest_FrameViewTester.la
+ kunittestmodrunner 2>&1 | perl $(srcdir)/checkFilter.pl
+