summaryrefslogtreecommitdiffstats
path: root/tools/kfile-plugins/abiword/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /tools/kfile-plugins/abiword/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'tools/kfile-plugins/abiword/Makefile.am')
-rw-r--r--tools/kfile-plugins/abiword/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/kfile-plugins/abiword/Makefile.am b/tools/kfile-plugins/abiword/Makefile.am
new file mode 100644
index 00000000..b24e4e14
--- /dev/null
+++ b/tools/kfile-plugins/abiword/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for gnumeric file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(KOFFICE_INCLUDES) $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_abiword.h
+
+kde_module_LTLIBRARIES = kfile_abiword.la
+
+kfile_abiword_la_SOURCES = kfile_abiword.cpp
+kfile_abiword_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_abiword_la_LIBADD = $(LIB_KOFFICECORE)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = kfile_abiword.desktop
+servicesdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_abiword.pot