summaryrefslogtreecommitdiffstats
path: root/tools/tdefile-plugins/abiword/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2013-01-27 00:54:22 -0600
committerTimothy Pearson <[email protected]>2013-01-27 00:54:22 -0600
commit038b18b2df1da40baab30d62171766048a948095 (patch)
treeba99d50e3e7b3f2eccb63ba71aea4f6163ede37a /tools/tdefile-plugins/abiword/Makefile.am
parentd0baf2961c379b31587c6542625018c6177474d0 (diff)
downloadkoffice-038b18b2df1da40baab30d62171766048a948095.tar.gz
koffice-038b18b2df1da40baab30d62171766048a948095.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tools/tdefile-plugins/abiword/Makefile.am')
-rw-r--r--tools/tdefile-plugins/abiword/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/tdefile-plugins/abiword/Makefile.am b/tools/tdefile-plugins/abiword/Makefile.am
new file mode 100644
index 00000000..4bd75a15
--- /dev/null
+++ b/tools/tdefile-plugins/abiword/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for gnumeric file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(KOFFICE_INCLUDES) $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_abiword.h
+
+kde_module_LTLIBRARIES = tdefile_abiword.la
+
+tdefile_abiword_la_SOURCES = tdefile_abiword.cpp
+tdefile_abiword_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -ltdeparts
+tdefile_abiword_la_LIBADD = $(KOFFICE_LIBS)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = tdefile_abiword.desktop
+servicesdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_abiword.pot