summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/viewplugins/screenshot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'chalk/plugins/viewplugins/screenshot/Makefile.am')
-rw-r--r--chalk/plugins/viewplugins/screenshot/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/chalk/plugins/viewplugins/screenshot/Makefile.am b/chalk/plugins/viewplugins/screenshot/Makefile.am
new file mode 100644
index 00000000..9887b7a2
--- /dev/null
+++ b/chalk/plugins/viewplugins/screenshot/Makefile.am
@@ -0,0 +1,27 @@
+chalkrcdir = $(kde_datadir)/chalkplugins
+chalkrc_DATA = screenshot-chalk.rc
+
+EXTRA_DIST = $(chalkrc_DATA)
+
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../chalkcolor/ \
+ -I$(srcdir)/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = chalkscreenshot.la
+
+chalkscreenshot_la_SOURCES = screenshot.cpp ksnapshot.cpp regiongrabber.cpp ksnapshotwidget.ui
+noinst_HEADERS = screenshot.h ksnapshot.h regiongrabber.h ksnapshotwidget.h ksnapshotwidget.ui.h
+
+chalkscreenshot_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lkdecore -lkdeui -lkjs -lkdefx -lkio -lkparts -L../../../../chalk/chalkcolor/.libs -lchalkcolor -L../../../../chalk/core/.libs -lchalkimage \
+ -L../../../../chalk/ui/.libs -lchalkui -L../../../../lib/kofficeui/.libs -lkofficeui -lkdeprint
+chalkscreenshot_la_LIBADD = ../../../libchalkcommon.la
+
+kde_services_DATA = chalkscreenshot.desktop
+
+chalkscreenshot_la_METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kscreenshot_plugin.pot