summaryrefslogtreecommitdiffstats
path: root/karbon/plugins/imagetool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'karbon/plugins/imagetool/Makefile.am')
-rw-r--r--karbon/plugins/imagetool/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/karbon/plugins/imagetool/Makefile.am b/karbon/plugins/imagetool/Makefile.am
new file mode 100644
index 00000000..491c0f86
--- /dev/null
+++ b/karbon/plugins/imagetool/Makefile.am
@@ -0,0 +1,14 @@
+kde_services_DATA = karbonimagetool.desktop
+
+INCLUDES = $(KOFFICE_INCLUDES) -I$(top_srcdir)/karbon -I$(top_srcdir)/karbon/core $(all_includes)
+
+kde_module_LTLIBRARIES = karbon_imagetoolplugin.la
+
+karbon_imagetoolplugin_la_SOURCES = imagetoolplugin.cc vimagetool.cc
+karbon_imagetoolplugin_la_LIBADD = $(LIB_KPARTS) $(LIB_KOFFICEUI) \
+ ../../libkarboncommon.la
+
+karbon_imagetoolplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+