summaryrefslogtreecommitdiffstats
path: root/kexi/plugins/migration/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kexi/plugins/migration/Makefile.am')
-rw-r--r--kexi/plugins/migration/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kexi/plugins/migration/Makefile.am b/kexi/plugins/migration/Makefile.am
new file mode 100644
index 00000000..e496773e
--- /dev/null
+++ b/kexi/plugins/migration/Makefile.am
@@ -0,0 +1,20 @@
+include $(top_srcdir)/kexi/Makefile.global
+
+kde_module_LTLIBRARIES = kexihandler_migration.la
+
+kexihandler_migration_la_SOURCES = keximigrationpart.cpp
+
+kexihandler_migration_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module
+kexihandler_migration_la_LIBADD = ../../core/libkexicore.la \
+ ../../migration/libkeximigrate.la
+
+INCLUDES= -I$(top_srcdir)/kexi/core -I$(top_srcdir)/kexi \
+ -I$(top_srcdir)/kexi/widget -I$(top_srcdir)/kexi/migration \
+ -I$(top_srcdir)/kexi/kexiDB $(all_includes)
+
+METASOURCES = AUTO
+
+servicesdir=$(kde_servicesdir)/kexi
+services_DATA=keximigrationhandler.desktop
+
+include ../Makefile.common