summaryrefslogtreecommitdiffstats
path: root/kword/mailmerge/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kword/mailmerge/Makefile.am')
-rw-r--r--kword/mailmerge/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kword/mailmerge/Makefile.am b/kword/mailmerge/Makefile.am
new file mode 100644
index 00000000..8d596413
--- /dev/null
+++ b/kword/mailmerge/Makefile.am
@@ -0,0 +1,22 @@
+
+KDE_CXXFLAGS = $(USE_RTTI)
+INCLUDES = $(KOFFICE_INCLUDES) -I$(top_srcdir)/lib/kformula $(KOTEXT_INCLUDES) -I$(top_srcdir)/kword $(all_includes)
+
+kde_module_LTLIBRARIES = kwmailmerge_classic.la
+
+## Plugin encapsulating the (old) internally stored style
+kwmailmerge_classic_la_SOURCES = KWClassicSerialDataSource.cpp
+kwmailmerge_classic_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kwmailmerge_classic_la_LIBADD = ../libkwmailmerge_interface.la $(LIB_KDEUI) $(LIB_KOTEXT)
+
+METASOURCES = AUTO
+
+services_DATA=kwserialletter_classic.desktop
+servicesdir=$(kde_servicesdir)
+
+if include_sql
+SQLDIRECTORY=sql
+endif
+
+SUBDIRS = . kabc kspread $(SQLDIRECTORY)
+