summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-01-01 18:12:19 +0100
committerSlávek Banko <[email protected]>2019-01-01 18:12:19 +0100
commit7854904d2f5dddea8d6e8609fff7ce199fae1358 (patch)
tree954aa8b70c00d067484fe5fd26833d7da34a712c /po/CMakeLists.txt
parenta9090542668749087e30d31013d7e3eab1ec4701 (diff)
downloadkonversation-7854904d2f5dddea8d6e8609fff7ce199fae1358.tar.gz
konversation-7854904d2f5dddea8d6e8609fff7ce199fae1358.zip
Add CMakeL10n rules.
Create translation template. Modify CMake rules for translations to make them independent of languages. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index dc6bb77..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,12 +1,9 @@
-#################################################
-#
-# (C) 2012 Golubev Alexander
-# fatzer2 (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
+# build translations if some are already available
-tde_auto_add_subdirectories( )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )