summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-03-02 16:03:48 +0100
committerSlávek Banko <[email protected]>2019-03-02 16:04:26 +0100
commitdb37455b62d2357741dce5fd099eba4c5ebac0de (patch)
tree8aa07454e88aeaa81c19fe8ef02400a6d42fa067 /CMakeLists.txt
parent7e4b17f262de7fb3610c323803316d88532ed539 (diff)
downloadkooldock-db37455b62d2357741dce5fd099eba4c5ebac0de.tar.gz
kooldock-db37455b62d2357741dce5fd099eba4c5ebac0de.zip
Change welcomeMsg from TQString to const char* and use I18N_NOOP.
This resolves FTBFS with TQT_NO_ASCII_CAST and ensure that the string will be added to the translation template. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f5f02c..20b1b7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )