summaryrefslogtreecommitdiffstats
path: root/conduits/abbrowserconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/abbrowserconduit/CMakeLists.txt
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/abbrowserconduit/CMakeLists.txt')
-rw-r--r--conduits/abbrowserconduit/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/conduits/abbrowserconduit/CMakeLists.txt b/conduits/abbrowserconduit/CMakeLists.txt
new file mode 100644
index 0000000..2459d1d
--- /dev/null
+++ b/conduits/abbrowserconduit/CMakeLists.txt
@@ -0,0 +1,46 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+set(conduit_abbrowser_SRCS
+ resolutionDialog.cc
+ abbrowser-factory.cc
+ abbrowser-setup.cc
+ kabcRecord.cc
+ abbrowser-conduit.cc
+)
+
+set(conduit_abbrowser_UIS
+ resolutionDialog_base.ui
+ kaddressbookConduit.ui
+)
+
+set(conduit_abbrowser_KCFGS
+ abbrowserSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_abbrowser_SRCS ${conduit_abbrowser_KCFGS})
+kde3_add_ui_files(conduit_abbrowser_SRCS ${conduit_abbrowser_UIS})
+kde3_automoc(${conduit_abbrowser_SRCS})
+add_library(conduit_address SHARED ${conduit_abbrowser_SRCS})
+target_link_libraries(conduit_address kabc_file kabc)
+set_target_properties(conduit_address PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
+ PREFIX ""
+)
+
+kde3_install_libtool_file(conduit_address)
+
+install(
+ TARGETS conduit_address
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES abbrowser_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES abbrowserconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)
+