summaryrefslogtreecommitdiffstats
path: root/conduits/timeconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/timeconduit/CMakeLists.txt
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/timeconduit/CMakeLists.txt')
-rw-r--r--conduits/timeconduit/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/conduits/timeconduit/CMakeLists.txt b/conduits/timeconduit/CMakeLists.txt
new file mode 100644
index 0000000..e980e72
--- /dev/null
+++ b/conduits/timeconduit/CMakeLists.txt
@@ -0,0 +1,44 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+set(conduit_time_SRCS
+ time-conduit.cc
+ time-factory.cc
+ time-setup.cc
+)
+
+set(conduit_time_UIS
+ time-setup_dialog.ui
+)
+
+set(conduit_time_KCFGS
+ timeConduitSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_time_SRCS ${conduit_time_KCFGS})
+kde3_add_ui_files(conduit_time_SRCS ${conduit_time_UIS})
+kde3_automoc(${conduit_time_SRCS})
+add_library(conduit_time SHARED ${conduit_time_SRCS})
+
+kpilot_rpath(conduit_time)
+
+set_target_properties(
+ conduit_time PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ PREFIX ""
+)
+
+kde3_install_libtool_file(conduit_time)
+
+install(
+ TARGETS conduit_time
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES time_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES timeconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)