summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 8 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index be883de..b0429b1 100644
--- a/configure.in
+++ b/configure.in
@@ -87,7 +87,7 @@ dnl PACKAGE set before
AC_C_BIGENDIAN
AC_CHECK_KDEMAXPATHLEN
-AC_ARG_WITH(sqlite, AC_HELP_STRING([--without-sqlite], [Don't compile SQLite backend support]), , with_sqlite=yes)
+AC_ARG_WITH(sqlite3, AC_HELP_STRING([--without-sqlite3], [Don't compile SQLite3 backend support]), , with_sqlite3=yes)
AC_ARG_WITH(mysql, AC_HELP_STRING([--without-mysql], [Don't compile MySQL backend support]), , with_mysql=yes)
AC_ARG_WITH(postgresql, AC_HELP_STRING([--without-postgresql], [Don't compile PostgreSQL backend support]), , with_postgresql=yes)
@@ -115,27 +115,12 @@ fi
dnl ------ Check for the SQLite headers -----
-AC_DEFUN([AC_HAVE_SQLITE],
-[
- AC_DEFINE(HAVE_SQLITE, 1, [have SQLite])
- have_sqlite=true
- SQLITE_LIB="-lsqlite"
- AC_SUBST(SQLITE_LIB)
-])
-
-AC_DEFUN([AC_NO_SQLITE],
-[
- AC_DEFINE(HAVE_SQLITE, 0, [have SQLite])
- have_sqlite=false
-])
-
AC_DEFUN([AC_HAVE_SQLITE3],
[
AC_DEFINE(HAVE_SQLITE3, 1, [have SQLite3])
have_sqlite3=true
- AC_NO_SQLITE
- SQLITE_LIB="-lsqlite3"
- AC_SUBST(SQLITE_LIB)
+ SQLITE_LIB3="-lsqlite3"
+ AC_SUBST(SQLITE_LIB3)
])
AC_DEFUN([AC_NO_SQLITE3],
@@ -144,32 +129,23 @@ AC_DEFUN([AC_NO_SQLITE3],
have_sqlite3=false
])
-if test "x$with_sqlite" != "xno"; then
+if test "x$with_sqlite3" != "xno"; then
KDE_CHECK_HEADER(sqlite3.h,
AC_HAVE_SQLITE3,
AC_NO_SQLITE3
)
-
- if test "x$have_sqlite3" = "xfalse"; then
- KDE_CHECK_HEADER(sqlite.h,
- AC_HAVE_SQLITE,
- AC_NO_SQLITE
- )
- fi
-
else
- AC_NO_SQLITE
AC_NO_SQLITE3
fi
dnl ----------- Should I link or should I not link? ---------
AM_CONDITIONAL(link_lib_MYSQL, test x$have_mysql = xtrue)
AM_CONDITIONAL(link_lib_POSTGRESQL, test x$have_postgresql = xtrue)
-AM_CONDITIONAL(link_lib_SQLITE, test x$have_sqlite = xtrue || test x$have_sqlite3 = xtrue)
+AM_CONDITIONAL(link_lib_SQLITE, test x$have_sqlite3 = xtrue)
dnl ----------- Should Krecipes be built at all? ------------
if test "x$have_mysql" = "xfalse" && test "x$have_postgresql" = "xfalse"; then
- if test "x$have_sqlite" = "xfalse" && test "x$have_sqlite3" = "xfalse"; then
+ if test "x$have_sqlite3" = "xfalse"; then
DO_NOT_COMPILE="$DO_NOT_COMPILE krecipes"
will_not_build_krecipes=true
fi
@@ -227,7 +203,7 @@ fi
echo "- -"
-if test "x$have_sqlite" = "xtrue" || test "x$have_sqlite3" = "xtrue"; then
+if test "x$have_sqlite3" = "xtrue"; then
echo "- SQLite Found..................... YES -"
else
echo "- SQLite Found..................... NO -"
@@ -247,7 +223,7 @@ echo "You can get SQLite from: http://www.hwaci.com/sw/sqlite/"
echo "Or MySQL from: http://www.mysql.com"
else if test "x$have_mysql" = "xtrue"; then
- if test "x$have_sqlite" = "xtrue" || test "x$have_sqlite3" = "xtrue"; then
+ if test "x$have_sqlite3" = "xtrue"; then
echo "- -"
echo "- Fine, you can build Krecipes now -"
echo "------------------------------------------------"