summaryrefslogtreecommitdiffstats
path: root/src/backends/PostgreSQL/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/backends/PostgreSQL/Makefile.am')
-rw-r--r--src/backends/PostgreSQL/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/backends/PostgreSQL/Makefile.am b/src/backends/PostgreSQL/Makefile.am
new file mode 100644
index 0000000..dac2623
--- /dev/null
+++ b/src/backends/PostgreSQL/Makefile.am
@@ -0,0 +1,17 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir) -I$(srcdir)/.. -I$(srcdir)/../.. $(all_includes)
+
+
+# Instructions for building the convenience library
+noinst_LTLIBRARIES=libkrecpsql.la
+libkrecpsql_la_SOURCES=psqlrecipedb.cpp
+libkrecpsql_la_METASOURCES=AUTO
+
+
+#the library search path.
+libkrecpsql_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)