summaryrefslogtreecommitdiffstats
path: root/src/importers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/importers/Makefile.am')
-rw-r--r--src/importers/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/importers/Makefile.am b/src/importers/Makefile.am
new file mode 100644
index 0000000..28ab637
--- /dev/null
+++ b/src/importers/Makefile.am
@@ -0,0 +1,15 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../backends $(all_includes)
+
+noinst_LTLIBRARIES=libkrecipesimporters.la
+libkrecipesimporters_la_SOURCES = mx2importer.cpp mmfimporter.cpp mxpimporter.cpp nycgenericimporter.cpp recipemlimporter.cpp baseimporter.cpp kreimporter.cpp rezkonvimporter.cpp kredbimporter.cpp
+libkrecipesimporters_la_METASOURCES=AUTO
+
+#the library search path.
+libkrecipesimporters_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+noinst_HEADERS = kreimporter.h