summaryrefslogtreecommitdiffstats
path: root/src/widgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/widgets/Makefile.am')
-rw-r--r--src/widgets/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/widgets/Makefile.am b/src/widgets/Makefile.am
new file mode 100644
index 0000000..b92e241
--- /dev/null
+++ b/src/widgets/Makefile.am
@@ -0,0 +1,28 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+noinst_LTLIBRARIES=libkrecipeswidgets.la
+
+libkrecipeswidgets_la_SOURCES= \
+ krelistview.cpp kremenu.cpp \
+ paneldeco.cpp ingredientlistview.cpp unitlistview.cpp \
+ propertylistview.cpp prepmethodlistview.cpp categorylistview.cpp \
+ authorlistview.cpp recipelistview.cpp categorycombobox.cpp \
+ kretextedit.cpp dblistviewbase.cpp \
+ conversiontable.cpp fractioninput.cpp ingredientcombobox.cpp \
+ headercombobox.cpp prepmethodcombobox.cpp \
+ inglistviewitem.cpp kdateedit.cpp kdatepickerpopup.cpp \
+ headerlistview.cpp ratingwidget.cpp kwidgetlistbox.cpp \
+ ratingdisplaywidget.ui criteriacombobox.cpp ingredientinputwidget.cpp \
+ unitcombobox.cpp amountunitinput.cpp weightinput.cpp
+
+
+libkrecipeswidgets_la_METASOURCES=AUTO
+
+#the library search path.
+libkrecipeswidgets_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)